Chat Support Issues
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Sep 03, 2020 - 15:06 EDT
Investigating
We are having issues with some inbound Member Support chats from our website. If you are having difficulty reaching our Support team through chat, please try again or call our NA Support team at (866) 679-9129
Posted Sep 03, 2020 - 12:03 EDT
This incident affected: Contact (Chat).