id.me Hardware Checkout Issue

Incident Report for Peloton

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 16:42 EST

Identified

Users who have verified with ID.me are currently unable to add any CFUs to cart. Users can clear their cookies to workaround this issue.
Posted Nov 18, 2025 - 13:31 EST
This incident affected: Website (Peloton Checkout (onepeloton.com/checkout)).