Issue Checking out in the United Kingdom and Canada
Incident Report for Peloton
Resolved
The issue with Members experiencing an issue with checking our is now resolved.
Posted Nov 25, 2019 - 10:48 EST
Investigating
We are investigating an issue with Members having trouble checking out on onepeloton.co.uk and onepeloton.ca. If you need assistance purchasing a Peloton Bike, please give our Inside Sales team a call and they'd be happy to assist you.
United Kingdom- +44.808.169.6469
Canada- +1.833.821.0099
Posted Nov 25, 2019 - 09:30 EST
This incident affected: Website (onepeloton.ca, onepeloton.co.uk).