Peloton Website Degraded Performance
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Aug 16, 2022 - 17:28 EDT
Investigating
We are investigating an issue with our website. This may impact your ability to browse, shop, or log in. If refreshing doesn't work, please try again in a few minutes.
Posted Aug 16, 2022 - 11:16 EDT
This incident affected: Website (Peloton Profile/Workout History (members.onepeloton.com)).