Badge Descriptions Not Displaying

Incident Report for Peloton

Resolved

This incident has been resolved.
Posted Aug 20, 2025 - 13:51 EDT

Identified

We're currently aware of an issue where badge descriptions are not displaying after workouts on devices (badges display correctly in the Peloton App). This is a known bug that has already been fixed and will be included in the next app release.
Posted Jul 28, 2025 - 17:55 EDT