Live and On-Demand Leaderboard
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Jun 21, 2020 - 10:33 EDT
Identified
The team has identified the issue with the Leaderboard. This may impact your ability to view the friends you are following on the Leaderboard during a live or on-demand class. The team will be releasing an update to resolve the issue shortly.
Posted Jun 21, 2020 - 09:52 EDT
Investigating
We are investigating an issue with the Leaderboard. This may impact your ability to view the friends you are following on the Leaderboard during a live or on-demand class.
Posted Jun 20, 2020 - 18:00 EDT
This incident affected: Bike/Tread/App/Row (Leaderboard).