Peloton Bike Checkout Issues
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Oct 17, 2022 - 10:28 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 14, 2022 - 21:36 EDT
Investigating
We are currently investigating issues during checkout with the Peloton Bike. Please try again shortly.
Posted Oct 14, 2022 - 18:03 EDT
This incident affected: Website (Peloton Site - US (onepeloton.com), Peloton Site - Canada (onepeloton.ca)).