Live Class Issues
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Aug 30, 2020 - 10:50 EDT
Identified
We have identified streaming issues from PSNY that are causing issues with live classes. Some classes may be rescheduled or canceled. We apologize for any effect this has on your workout and will update this page with more information.
Posted Aug 30, 2020 - 09:24 EDT
This incident affected: Bike/Tread/Digital (Live Classes) and Retail/Studio (Peloton Studios New York (PSNY)).