On-demand Leaderboard Unavailable
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Sep 30, 2021 - 18:43 EDT
Investigating
We are investigating an issue with leaderboards in on-demand classes.
Posted Sep 30, 2021 - 11:26 EDT
This incident affected: Bike/Tread/Digital (Leaderboard).