Intermittent Issue
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Dec 27, 2021 - 12:03 EST
Investigating
We are currently experiencing intermittent issues accessing Peloton services and content. If you are having any connection issues we recommend trying again in a few minutes. We apologize for any impact this may have on your workout.
Posted Dec 27, 2021 - 11:26 EST
This incident affected: Bike/Tread/App (Member Login, Live Classes, On Demand Classes, Leaderboard, Activation).