Issues loading Workout History
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Feb 19, 2020 - 12:59 EST
Update
Our team is currently investigating an issue that prevents the member's Workout History and on-demand classes loading on the web. Please continue to monitor this page for updates.
Posted Feb 19, 2020 - 12:51 EST
Investigating
Our team is currently investigating an issue that prevents the member's Workout History and on-demand classes loading on the web. Please continue to monitor this page for updates.
Posted Feb 19, 2020 - 12:46 EST
This incident affected: Bike/Tread/Digital (On Demand Classes) and Website (Member Profile/Workout History (members.onepeloton.com)).