Intermittent issue impacting some members ability to add a class to their schedule or view their schedule.

Incident Report for Peloton

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 08, 2025 - 21:24 EDT

Investigating

We are currently investigating the issue.
Posted Jun 08, 2025 - 13:20 EDT