Leaderboard Issues

Incident Report for Peloton

Resolved

This incident has been resolved.
Posted Aug 16, 2020 - 14:59 EDT

Investigating

We are currently investigating an issues causing some members to experience problems with the leaderboard and high fives. We apologize for any effect this has on your workout.
Posted Aug 16, 2020 - 11:30 EDT
This incident affected: Bike/Tread/App/Row (Leaderboard).