Service Interruption - Phone Platform
Incident Report for Peloton
Resolved
The issue impacting our phone platform has been resolved.
Posted Mar 22, 2022 - 13:30 EDT
Monitoring
The issue impacting our phone platform has been resolved. We will continue to monitor the status.
Posted Mar 22, 2022 - 13:21 EDT
Investigating
We are currently investigating an issue that is affecting our phone platform. If you need assistance, please reach out to our Support Team via chat on support.onepeloton.com or via email at support@onepeloton.com.
We apologize for any inconvenience this may have caused.
Posted Mar 22, 2022 - 12:37 EDT
This incident affected: Contact (Phone).