Live and On-Demand Leaderboard
Incident Report for Peloton
Resolved
The performance issues with the Leaderboard have now been resolved.
Posted Nov 10, 2021 - 22:28 EST
Monitoring
We are beginning to see recovery with Leaderboard performance. Our team will continue to monitor the situation.
Posted Nov 10, 2021 - 19:53 EST
Investigating
We are investigating an issue with the Leaderboard. This may impact your ability to view, sort, or track your output on the Leaderboard during a live or on-demand class. This may impact the class history data that is posted for workouts during this time.
Posted Nov 10, 2021 - 15:16 EST
This incident affected: Bike/Tread/App (Leaderboard).