Workouts Not Being Credited for Programs

Incident Report for Peloton

Resolved

Team resolved this issue and has backfilled all Program credit for workouts taken over the weekend 2/6-2/9 as of 2/11 at 10am.
Posted Feb 11, 2026 - 11:14 EST

Monitoring

Team has mitigated the issue, starting Monday 2/9 at 10amEST members taking classes will now get Program credit. Team is looking into backfilling program credit, expect all Program Credit to be complete by end of the week
Posted Feb 09, 2026 - 09:59 EST

Investigating

Team is investigating an issue with workouts not being credited for Program progress.
Posted Feb 09, 2026 - 09:36 EST