Returns Site Not Loading for Some Members
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Feb 04, 2020 - 20:15 EST
Investigating
We are currently investigating an issue where returns.onepeloton.com is not loading for some members. We appreciate your patience while we look into this issue further.
Posted Feb 04, 2020 - 16:37 EST
This incident affected: Website (Peloton Site - US (onepeloton.com)).