Member Support and Sales Phone Experiencing Issues
Incident Report for Peloton
Resolved
This incident has been resolved, we apologize for any issues that you had contacting our team.
Posted Nov 25, 2020 - 15:00 EST
Monitoring
We've identified the issue and are starting to see recovery of our phone system. We are continuing to monitor the situation.
Posted Nov 25, 2020 - 14:14 EST
Investigating
We are investigating an issue reported by our Members experiencing trouble contacting us via phone. Our team is currently available and ready to assist you over chat at support.onepeloton.com.
Posted Nov 25, 2020 - 13:52 EST
This incident affected: Contact (Phone).