Logins on Strava are currently failing preventing members from connecting to Strava (existing connections are unaffected.)

Incident Report for Peloton

Resolved

This incident has been resolved.
Posted Jun 10, 2025 - 15:29 EDT

Investigating

The team is working with Strava to investigate and resolve the issue. If you encounter this issue, you can connect to Strava on the Web as a workaround until we can resolve the connection issue on Peloton devices.
Posted May 06, 2025 - 13:51 EDT
This incident affected: Integrations (Strava).