Some Financing Orders Not Being Placed Properly
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Aug 30, 2024 - 18:01 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 30, 2024 - 12:16 EDT
Investigating
Team is investigating an issue where some order placed via our financing partners are not being placed properly. Members can reach out to our web sales team via chat or phone to get this issue resolved.
Posted Aug 29, 2024 - 19:03 EDT
This incident affected: Integrations (Affirm).