Issue with Live or On-Demand Classes
Incident Report for Peloton
Resolved
This incident has been resolved. We apologize for any interruption to your workout.
Posted Jul 15, 2022 - 14:11 EDT
Monitoring
We've released an update and Members can now log in and access Peloton classes. We sincerely apologize for any interruption to your workout.
Posted Jul 15, 2022 - 13:28 EDT
Update
We are continuing to investigate this issue.
Posted Jul 15, 2022 - 12:49 EDT
Update
We are continuing to investigate this issue.
Posted Jul 15, 2022 - 12:24 EDT
Update
We are continuing to investigate this issue.
Posted Jul 15, 2022 - 12:21 EDT
Update
We are continuing to investigate this issue.
Posted Jul 15, 2022 - 12:20 EDT
Investigating
We are investigating an issue with Peloton classes. This may impact your ability to login, browse or take live or on-demand classes.
Posted Jul 15, 2022 - 12:18 EDT
This incident affected: Bike/Tread/App/Row (Member Login, Live Classes, On Demand Classes, Activation, Peloton App).