Order Confirmation Page is not loading
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Aug 22, 2024 - 17:42 EDT
Monitoring
A fix has been implemented and we are monitoring the results. Members should now be able to see the order confirmation page and schedule their deliveries directly from that page.
Posted Aug 22, 2024 - 17:09 EDT
Investigating
Team is investigating an issue with our order confirmation page. Members orders are still being placed and processed at this time but unable to see confirmation of purchase. Members can access order confirmation information and schedule their delivery from the confirmation email
Posted Aug 22, 2024 - 16:43 EDT
This incident affected: Website (Peloton Site - (onepeloton.com)).