Safari Browser Issue

Incident Report for Peloton

Resolved

This incident has been resolved.
Posted Jul 08, 2022 - 09:04 EDT

Update

The issue with the "My Membership" and "Orders" pages not loading properly on Safari browsers has been resolved.
Posted Jul 07, 2022 - 17:27 EDT

Investigating

We are investigating an issue with the "My Membership" and "Orders" pages not loading properly on Safari browsers. As a workaround, please use another web browser as we work to fix this issue.
Posted Jul 07, 2022 - 12:43 EDT
This incident affected: Website (Peloton Site - (onepeloton.com)).