Member Login Issue
Incident Report for Peloton
Resolved
The issue impacting logging in has been resolved.
Posted Jun 08, 2023 - 17:34 EDT
Investigating
Our Team is investigating an issue that is impacting Members' ability to log in to their account.
Posted Jun 08, 2023 - 16:54 EDT
This incident affected: Bike/Tread/App/Row (Member Login).