Checkout Interruption
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Apr 28, 2022 - 11:18 EDT
Monitoring
Our Team has identified an issue that prevented orders from being placed. We have implemented a fix and will continue to monitor the status.
Posted Apr 27, 2022 - 17:43 EDT
This incident affected: Integrations (Checkout).