Issue with Support Phone Line
Incident Report for Peloton
Resolved
We resolved the issue with our Support phone number. We apologize for any issues with connecting with our Member Support team.
Posted Apr 17, 2019 - 15:17 EDT
Investigating
We are investigating an issue with our Support phone number. We apologize for the issue and are working to resolve the problem as quickly as possible. In the meantime, you can chat with us on support.onepeloton.com and our Member Support team will assist you.
Posted Apr 17, 2019 - 15:10 EDT
This incident affected: Website (Peloton Site - (onepeloton.com)).