iOS Mobile App: Team Challenge notifications are taking members to an error page.

Incident Report for Peloton

Resolved

This incident has been resolved. Update to the latest iOS app version!
Posted Aug 14, 2026 - 11:58 EDT

Identified

The issue has been identified and we are working to roll out a fix to members soon.
Posted Jul 30, 2026 - 15:44 EDT

Investigating

iOS Mobile App: Team Challenge notifications are taking members to an error page. We have paused the rollout of v.15.129.0 as the team is actively investigating.
Posted Jul 30, 2026 - 12:58 EDT
This incident affected: Bike/Tread/App/Row (Peloton App).