Latest iOS App version (v.15.127.0) is crashing on launch. We have paused the rollout and are investigating next steps.

Incident Report for Peloton

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 29, 2026 - 20:10 EDT

Investigating

Latest iOS App version (v.15.127.0) is crashing on launch. We have paused the rollout and are investigating next steps. Members who are still on v.15.126.0 are unaffected.
Posted Jun 29, 2026 - 13:50 EDT
This incident affects: Bike/Tread/App/Row (Peloton App).