Home Screen Loading Incident
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Apr 07, 2023 - 16:12 EDT
Monitoring
A fix has been implemented and we are monitoring the results. We apologize for any interruption to your workout.
Posted Apr 07, 2023 - 11:34 EDT
Investigating
Our team is investigating an issue with the Peloton home screen not loading that is impacting some Members from accessing classes on Bike/Bike+/Tread/Row.
Posted Apr 07, 2023 - 09:42 EDT
This incident affected: Bike/Tread/App/Row (Live Classes, On Demand Classes).