Some members might have issues accessing some features across Bike, Tread, Row, Guide and App (ex. Programs, Schedule)

Incident Report for Peloton

Resolved

This incident has been resolved.
Posted Aug 18, 2025 - 10:16 EDT

Identified

The team has identified the issues and is working on a fix.
Posted Aug 14, 2025 - 10:31 EDT
This incident affected: Bike/Tread/App/Row (Peloton App, Connected Fitness Tablets).