Rider Profile
Incident Report for Peloton
Resolved
A fix has been implemented and we are monitoring the results.
If affected, please try the following steps to resolve the blank rider selection page:
Put tablet to sleep for 2-3 minutes
Wake up tablet to either see that the app update is in progress or has already completed.
Posted Oct 13, 2021 - 16:09 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
If affected, please try the following steps to resolve the blank rider selection page:
Put tablet to sleep for 2-3 minutes
Wake up tablet to either see that the app update is in progress or has already completed.
Posted Oct 13, 2021 - 13:06 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 12, 2021 - 22:45 EDT
Investigating
We are investigating an issue where the login page is displaying a blank screen on some connected fitness devices.
Posted Oct 12, 2021 - 18:57 EDT
This incident affected: Bike/Tread/Digital (Member Login).