CA and DE Support Site
Incident Report for Peloton
Resolved
The CA and DE support sites are accessible again.
Posted 15 days ago. Sep 04, 2019 - 16:40 EDT
Identified
support.onepeloton.ca and support.onepeloton.de are currently not accessible. To reach support, please visit our US site at support.onepeloton.com. We apologize for any inconvenience.
Posted 15 days ago. Sep 04, 2019 - 12:58 EDT
This incident affected: Website (Peloton Support (support.onepeloton.com)).