Member emails not being sent
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Nov 21, 2024 - 12:00 EST
Monitoring
A subset of emails (password reset & order confirmation) were not sent since 6pm yesterday (11/20). The cause has been identified and a fix is in place. We will continue to monitor and provide an update when resolved.
Posted Nov 21, 2024 - 11:18 EST