Some Members Reporting Issues Accessing their Schedule

Incident Report for Peloton

Resolved

This incident has been resolved.
Posted Mar 21, 2025 - 16:48 EDT

Investigating

We are currently investigating this issue.
Posted Mar 04, 2025 - 11:47 EST
This incident affected: Bike/Tread/App/Row (Connected Fitness Tablets).