UK and Germany Support Outage
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Mar 13, 2020 - 09:47 EDT
Investigating
We are currently experiencing issues contacting our UK and German support teams.
Posted Mar 13, 2020 - 09:03 EDT
This incident affected: Contact (Phone, Chat, Support Tickets).