Peloton Studios and Retail Closed to the Public
Incident Report for Peloton
Update
Out of an abundance of caution, we have decided to close all Peloton studios to the public to prioritize the health and safety of our team, community, and instructors. Classes will still be streamed live on the Peloton Bike, Tread and App. We apologize for any inconvenience and look forward to welcoming you to our studios in the future.

Some of our showrooms in select locations have reopened but require scheduling an appointment in advance. Please visit www.onepeloton.com/showrooms for updated hours and to schedule an appointment.
Posted Jul 07, 2020 - 21:49 EDT
Update
Out of an abundance of caution, we have decided to close all Peloton studios to the public to prioritize the health and safety of our team, community, and instructors. Classes will still be streamed live on the Peloton Bike, Tread and App. We apologize for any inconvenience and look forward to welcoming you to our studios in the future.

We have also decided to close all of our retail showrooms globally March 16-29, with current plans to reopen on March 30. Our e-commerce and inside sales channels remain open at one peloton dot com, and retail associates from your local showroom are available remotely by chat, phone or email, so we can continue to sell our Connected Fitness products to people during a time when they may need it most.
Posted Mar 16, 2020 - 10:19 EDT
Monitoring
Out of an abundance of caution, we have decided to close all Peloton studios to the public to prioritize the health and safety of our team, community, and instructors. Classes will still be streamed live on the Peloton Bike, Tread and App. We apologize for any inconvenience and look forward to welcoming you to our studios in the future.
Posted Mar 14, 2020 - 14:04 EDT
This incident affects: Retail/Studio (In-Store Purchases, Peloton Studios UK, Peloton Studios New York (PSNY)) and Website (Peloton Studio (studio.onepeloton.com)).