Intermittent Issues with Services
Incident Report for Peloton
Resolved
The issue with accessing Peloton services has been resolved. We apologize for any impact this may have had on your workout.
Posted Feb 22, 2022 - 14:46 EST
Update
We are seeing widespread recovery of Peloton services. We are still working to confirm all services are back and operational. We apologize for any impact this may have had on your workout.
Posted Feb 22, 2022 - 12:11 EST
Investigating
We are currently investigating an issue with Peloton services. This may impact your ability to take classes or access pages on the web. We apologize for any impact this may have on your workout.
Posted Feb 22, 2022 - 10:47 EST
This incident affected: Bike/Tread/App/Row (Member Login, Live Classes, On Demand Classes, Leaderboard, Activation) and Website (Peloton Profile/Workout History (members.onepeloton.com)).