Issue starting Stacked classes from Web

Incident Report for Peloton

Resolved

This incident has been resolved.
Posted Apr 09, 2026 - 20:05 EDT

Investigating

Issue: Users experienced intermittent failures when starting classes from stacks on web, causing classes to be removed from the user's stack.

Impact: users on web being unable to reliably start classes from stacks, resulting in premature class removal.
Posted Apr 07, 2026 - 11:54 EDT
This incident affected: Bike/Tread/App/Row (Peloton App) and Website (Peloton Profile/Workout History (members.onepeloton.com)).