Live and On Demand Classes
Incident Report for Peloton
Resolved
The issues with Peloton classes have now been resolved. We apologize for any issues this caused with your classes.
Posted Mar 10, 2020 - 20:38 EDT
Investigating
We are investigating an issue with Peloton classes. This may impact your ability to take live or on-demand classes.
Posted Mar 10, 2020 - 16:55 EDT
This incident affected: Bike/Tread/App/Row (Live Classes, On Demand Classes, Leaderboard).