Chat Issue
Incident Report for Peloton
Resolved
Our chat partners have implemented a fix for Support chat. We are monitoring the issue and will update this page if further issues arise. We apologize for any inconvenience.
Posted Jun 10, 2021 - 22:41 EDT
Investigating
We are currently investigating an issue with our chat platform that is preventing incoming chats from connecting with our agents.
Posted Jun 10, 2021 - 16:38 EDT
This incident affected: Contact (Chat).