Add To Cart and Checkout Outage

Incident Report for Peloton

Resolved

This incident has been resolved.
Posted Jun 13, 2025 - 09:36 EDT

Monitoring

Services are coming back online. We are monitoring to ensure the outage is fully resolved.
Posted Jun 12, 2025 - 16:20 EDT

Investigating

We are investigating an issue within our Ecommerce site. Add To Cart and Checkout are experience an outage, as well as certain product pages on onepeloton.com
Posted Jun 12, 2025 - 14:37 EDT
This incident affected: Website (Peloton Site - (onepeloton.com)).