Issues with contacting Member Support
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Jan 21, 2023 - 07:54 EST
Monitoring
The issue impacting our phone platform has been resolved. We will continue to monitor the status.
Posted Jan 20, 2023 - 18:52 EST
Update
Some Members are reporting intermittent issues calling into Peloton support. If you are experiencing an issue, our team is available immediately via phone at 866-693-9575 or chat at support.onepeloton.com
Posted Jan 20, 2023 - 17:27 EST
Update
Members are continuing to report intermittent issues calling into Peloton support.

If you are experiencing an issue, our team is available immediately via chat at support.onepeloton.com
Posted Jan 20, 2023 - 06:40 EST
Investigating
Some Members are reporting intermittent issues calling into Peloton support. If you are experiencing an issue, our team is available immediately via chat at support.onepeloton.com
Posted Jan 19, 2023 - 17:48 EST
This incident affected: Contact (Phone).