Checkout Issues
Incident Report for Peloton
Resolved
The issues with checkout have now been resolved.
Posted Oct 17, 2022 - 21:34 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 17, 2022 - 20:12 EDT
Investigating
We are currently investigating issues during checkout for Connected Fitness products in some regions. Please try again shortly.
Posted Oct 17, 2022 - 19:30 EDT
This incident affected: Website (Peloton Site - Canada (onepeloton.ca), Peloton Site - UK (onepeloton.co.uk), Peloton Site - Germany (onepeloton.de), Peloton Checkout (onepeloton.com/checkout), Peloton Site - AU(onepeloton.com.au)).