Issue with Bike Touchscreen Performance
Incident Report for Peloton
Resolved
We released an update to the Peloton Bike’s software on Monday evening, 5/13. This update improved the performance of the touchscreen and reduced the lagging issue reported by Members.
Posted 2 months ago. May 15, 2019 - 10:10 EDT
Monitoring
We released an update to the Peloton Bike’s software on Monday evening, 5/13. This update is intended to improve the performance of the touchscreen and reduce the lagging reported by Members.
Posted 2 months ago. May 14, 2019 - 12:07 EDT
Identified
Some Members have reported performance issues with their Peloton Bike touchscreen. The team is currently investigating these issues and we will have an update shortly.
Posted 2 months ago. May 13, 2019 - 16:56 EDT
This incident affected: Bike/Tread (Live Classes, On Demand Classes).