Netflix Beta failing to load for some members.
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Jan 06, 2025 - 17:46 EST
Investigating
We apologize for the inconvenience. We are currently investigating an issue with the Netflix beta on our connected fitness devices.
Posted Jan 04, 2025 - 15:30 EST
This incident affected: Bike/Tread/App/Row (Lanebreak and Entertainment).