Order Confirmation and Password Reset Degraded Performance
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Jan 05, 2023 - 12:05 EST
Investigating
Our team has identified an issue with order confirmation and password reset emails from being sent. We expect this issue to be resolved shortly.
Posted Jan 04, 2023 - 19:34 EST
This incident affected: Bike/Tread/App/Row (Member Login, Activation) and Website (Peloton Checkout (onepeloton.com/checkout)).