We are currently investigating an issue that may cause delays when starting a workout.

Incident Report for Peloton

Resolved

This incident has been resolved.
Posted Jul 12, 2026 - 08:16 EDT

Investigating

We are currently investigating this issue.
Posted Jul 12, 2026 - 05:32 EDT
This incident affected: Bike/Tread/App/Row (Live Classes, On Demand Classes).