Some members are reporting that they are unable to access Lanebreak.

Incident Report for Peloton

Resolved

This incident has been resolved.
Posted Feb 20, 2025 - 17:22 EST

Investigating

The team is investigating.
Posted Jan 06, 2025 - 18:06 EST
This incident affected: Bike/Tread/App/Row (Lanebreak and Entertainment).