London Peloton Studio Power Outage
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Jun 25, 2022 - 09:11 EDT
Monitoring
Power has been restored to the studio and systems are coming back online.
Posted Jun 24, 2022 - 12:12 EDT
Investigating
We are investigating an incident at our London Peloton Studio where we have lost power to the building.
Posted Jun 24, 2022 - 10:51 EDT
This incident affected: Retail/Studio (Peloton Studios UK).