Some members experiencing issues with Wear OS Heart Rate tracking experience

Incident Report for Peloton

Resolved

This incident has been resolved.
Posted Aug 21, 2025 - 14:53 EDT

Update

The latest version of Android App 3.57.0 is rolled out to 100% of members which resolves this issue. We are continuing to monitor for the rest of the day.
Posted Aug 19, 2025 - 12:38 EDT

Monitoring

A fix has been released with the latest App update, we are rolling this release out over the next few days. Once your app is updated to version 3.57.0 the issue should be resolved.
Posted Aug 18, 2025 - 10:15 EDT

Update

A fix has been identified and will begin rolling out updated App version week ending 8/15.
Posted Aug 05, 2025 - 14:30 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 05, 2025 - 14:14 EDT

Investigating

We are currently investigating this issue.
Posted Aug 05, 2025 - 10:07 EDT
This incident affected: Bike/Tread/App/Row (Peloton App).